[RndTbl] network problem

Dan Martin ummar143 at shaw.ca
Thu Feb 14 17:49:22 CST 2008

Kevin McGregor wrote:
> Well, no. By default, Shaw gives out one IP address per cable modem, 
> so if you change the connected device from the original router you 
> tried, to something else, it ignores the new device. Sometimes 
> powering down the cable modem (and waiting... hours? Days?) helps, but 
> the better solution is to call Shaw Internet tech support and tell 
> them you want your free second IP address activated. 
I only need one address.  I just need the NIC to get it.  I was trying 
to bypass the firewall to see if that's where the problem was. 

I am guessing the firewall is NOT the problem:
1)  I can connect on another machine on the LAN that should be handled 
the same way by the firewall.
2)  The second app used to work with the same firewall on the first machine.

Could a NIC 'partly' fail so that it can't accept an address by DHCP and 
will fail with some connections but not others?
> You may still have to power down and up the cable modem after they do 
> this. Shaw provides all Internet users with two IP addresses, but the 
> second one has to be activated on request.
> After that, you can try plugging in your computer or other device to 
> the cable modem to do tests - although I'd be loathe to do that with a 
> Windows 2000 machine.
> Kevin
> Dan Martin wrote:
>> I have a home LAN that uses a iptables firewall running on FC 4 on my 
>> gateway machine.  I run Win2K on an internal LAN machine that I use 
>> to run (among other things) 2 applications that contact remote 
>> servers.  Using SNAT in iptables, everything seemed to run fine, 
>> since all communications with the servers were initiated on my end 
>> and return packets were appropriately translated back.
>> ...
>> I plugged my Win2K machine directly to the cable modem and configured 
>> it to connect by DHCP.  I could not get an address for it.  Shaw 
>> believes the modem is working and trying to assign an address.
>> ...
>> It is suspicious that the NIC would not configure when plugged to the 
>> cable modem - but everything else works.  I can browse the web and 
>> get my mail.
>> Is this consistent with a NIC failure?  could it be something else?


Dr. Dan Martin, MD, CCFP, BSc, BCSc (Hon), MSc

GP Hospital Practitioner
Computer Scientist
ummar143 at shaw.ca
(204) 831-1746
answering machine always on

More information about the Roundtable mailing list