[RndTbl] "un-RAIDing" a Linux P2V

Wyatt Zacharias wyatt at magitech.ca
Mon Nov 30 13:25:37 CST 2015

So I'm attempting to virtualize one of our Redhat 5 boxes using VMWare's
P2V functionality, and it's copied all the data into the VM without any
trouble, but now I can't seem to get the virtual machine to boot because
it's not detecting the virtualized partitions correctly. The physical
system was using LVM on top of dm-raid to local disks. When VMWare
virtualized the disks, it created a single disk, and copied the LVM layout
onto it, so I think what's happening is on boot, the system is looking for
the RAID disks and can't find them. When I try to boot it, it says that it
can't find the logical volumes and goes into a kernel panic.

I've booted with a rescue disk, and when I run a pvscan on the new virtual
disk, all the volumes are there and can be mounted, so the problem must be
that the system isn't looking for the volumes in the right place. I've
tried changing the root device to /dev/sda in the device.map comfig file,
and I rebuilt the initrd file with both the --force-lvm-probe and
--omit-raid-modules and it still loads dm-raid on boot.

So how do I get the system to completely forget about RAID, and boot off
the new virtual disk? Is there a RAID config somewhere that I'm missing?

Wyatt Zacharias
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.muug.mb.ca/pipermail/roundtable/attachments/20151130/737a6560/attachment.html>

More information about the Roundtable mailing list