[RndTbl] [Board] NFS problems

Kevin McGregor kevin.a.mcgregor at gmail.com
Tue Jul 10 13:42:28 CDT 2018


I have an unprivileged account in FreeNAS ("vmware") and corresponding
group. I removed all of the volumes/NFS shares, then recreated them and
used the "Change Permissions" button like you suggested to assign "vmware"
the permissions and ownership. Then I changed the NFS configuration to map
all NFS access to vmware/vmware.

I still get mountd logging "mount request succeeded", and ESXi reports
"Can't connect to NFS server".

showmount -e shows
/mnt/data/stuff             Everyone

I tried configuring the share to "Map root user to..." and alternately
tried "Mapall users to...", and nothing changed.

Surely it's something trivial I've overlooked?

On Tue, Jul 10, 2018 at 11:36 AM Adam Thompson <athompso at athompso.net>

> Permissions.  No joke...  Root isn't root when NFS is involved.  Don't
> bother trying to get ESXi to try operating as non-root, as easily fly to
> the moon by flapping your arms.  Instead configure a host-specific override
> on FreeNAS mapping root to a real user on FreeNAS that owns the
> volume/subvolume/share.  Manually chown/chmod if necessary.
> (Storage -> select the shared volume, then the left-most icon at the
> bottom is "Change Permissions".)
> -Adam
> On 2018-07-10 10:54, Kevin McGregor wrote:
> Okay, so something *is* listening on port 2049 of <FreeNAS-IP> (confirmed
> with netstat -an4).
> I can ping both ways successfully.
> Both machines are on the same physical switch.
> Both are on the same subnet, same netmask, etc.
> Source (VMware ESXi) says "Unable to contact NFS server"
> ESXi firewall disabled with " esxcli network firewall set --enabled false "
> FreeNAS /var/log/messages has three entries like
> mountd[pid]: mount request successful from <IP> for <mountpoint>
> This is really annoying. What else can I try/check?
> On Tue, Jul 10, 2018 at 9:02 AM Kevin McGregor <kevin.a.mcgregor at gmail.com>
> wrote:
>> I'm trying to get FreeNAS (based on FreeBSD) to serve up NFS shares. It
>> keep failing with
>> nfsd: Can't bind to tcp addr *: Address already in use
>> Which doesn't make sense. I tried binding to a specific address (the IP
>> address of this server) and I get the same message, but with the IP address
>> instead of *.
>> No other services are running on this server, other than http (80). Where
>> do I start?
>> Thanks,
>> Kevin
> _______________________________________________
> Roundtable mailing list
> Roundtable at muug.ca
> https://muug.ca/mailman/listinfo/roundtable
> _______________________________________________
> Board mailing list
> Board at muug.ca
> https://muug.ca/mailman/listinfo/board
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://muug.ca/pipermail/roundtable/attachments/20180710/f868c7d2/attachment.html>

More information about the Roundtable mailing list