[RndTbl] key for ssh

Sean Walberg sean at ertw.com
Mon May 3 07:19:44 CDT 2010

Have you tried puttygen? (same place you get putty)

It'll load or generate a putty keypair.When you have a keypair loaded, it
shows you the exact string you will paste into authorized_keys on the


On Sun, May 2, 2010 at 10:24 PM, Kelly Leveille <kel at kelweb.ca> wrote:

> Rob,
> Is the Ubuntu server "rejecting your key" during the SSH login session? Are
> there any logs available from either WinSCP or from the SSH server? I think
> SSHD can provide some verbose real-time logging which might detail the
> error. Are trying to login as root when testing the keyed & password based
> logins?
> Sorry that's all questions & no answers but maybe some part of it will
> point you in the right direction.
> Kelly
> ----
> On Sun, May 2, 2010 at 4:17 PM, Robert Dyck <rbdyck2 at shaw.ca> wrote:
>> I am also trying to set up ssh. I installed OpenSSH on Ubuntu server, and
>> downloaded WinSCP for my Windows computer. Both machines are in my home
>> office right now, but the server will be relocated to a business office. I
>> will continue to administer the server so want access from my home office.
>> I
>> need the server to be secure, so I want to use key authentication. My
>> client
>> machine is Windows so I can't run ssh-copy-id, so I just copied the .pub
>> file to the server then copied it to authorized_keys. It's rejecting my
>> key.
>> I have passwords enabled for testing, but want to disable passwords when I
>> actually connect through the internet. I tried to have WinSCP generate the
>> keys and copy the .pub file to the server, and I generated keys on the
>> server and copied the private key to my Windows desktop. WinSCP requires
>> "importing" the private key, it adds some of it's own stuff such as the
>> client's MAC address. Either way the server just rejects the key.
>> I have ensured PubkeyAuthentication is yes, AuthoriedKeysFile is
>> uncommented, and issued the ssh restart command after each change to the
>> server's config file.
>> What am I doing wrong?
>> Rob Dyck
>> _______________________________________________
>> Roundtable mailing list
>> Roundtable at muug.mb.ca
>> http://www.muug.mb.ca/mailman/listinfo/roundtable
> _______________________________________________
> Roundtable mailing list
> Roundtable at muug.mb.ca
> http://www.muug.mb.ca/mailman/listinfo/roundtable

Sean Walberg <sean at ertw.com>    http://ertw.com/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.muug.mb.ca/pipermail/roundtable/attachments/20100503/10431ebf/attachment.html 

More information about the Roundtable mailing list