[RndTbl] Vmware and Ubuntu 8.04 (vmware tools install)

Mike Pfaiffer high.res.mike at gmail.com
Sun Apr 19 23:45:32 CDT 2009

Montana Quiring wrote:
> Hello,
> I would appreciate any advice on this.
> I'm using the latest Vmware Fusion on a Mac.
> In a VM image I've installed Ubuntu 8.4 Remix (it's the one that Dell
> tweaked for the Dell Mini's)
> The next step was to install the vmware tools since I had no networking...
> When I run:
> sudo ./vmware-install.pl
> ...the install ticks along OK until I get to this point:
> <SNIP>
> None of the pre-built vmmemctl modules for VMware Tools is suitable for your
> running kernel.  Do you want this program to try to build the vmmemctl module
> for your system (you need to have a C compiler installed on your system)?
> [yes]
> Using compiler "/usr/bin/gcc". Use environment variable CC to override.
> What is the location of the directory of C header files that match your running
> kernel? [/usr/src/linux/include] /usr/src/linux-headers-2.6.24-16/include
> The path "/usr/src/linux-headers-2.6.24-16/include" is a kernel header file
> directory, but it does not contain the file "linux/version.h" as expected.
> This can happen if the kernel has never been built, or if you have invoked the
> "make mrproper" command in your kernel directory.  In any case, you may want to
> rebuild your kernel.
> What is the location of the directory of C header files that match your running
> kernel? [/usr/src/linux/include]
> </SNIP>
> NOTE: I had to copy across (on a USB flash drive) and install the
> header files as they weren't already there (from what I could find)
> I've started the process of preparing to recompile the kernel, but got
> stuck in deb package hell trying to satisfy the dependancies of
> build-essential
> Can anyone offer any advice about how to get networking working, as
> that would make getting everything else working easier.

	I don't know if the situation has changed. However it turns out I had 
to do a separate install of C in order to get VMWare to work on an older 
install. The deb of gtk-gnutella will do it (apt-get install 
gtk-gnutella). Unfortunately the version in the repositories will 
install an out of date gtk-gnutella and may not work. Trying to install 
C by itself didn't work out too well for me.

	You may want to try VirtualBox. It seems to work fairly well. Their 
documents say they can run a VM from VMWare, but it didn't work when I 
tried it on a Mac about six months ago.


More information about the Roundtable mailing list