[RndTbl] Apache2 modules

Kevin McGregor kmcgregor at shaw.ca
Thu Jun 8 11:13:07 CDT 2006

I got it sorted out -- at least the compile/install process. I haven't tried the module itself yet.

It turns out that the compile step (the first call to apxs2) ends up putting the .so module into ./.libs! This is the default for libtool, so that would be fine, except for some reason the next call to apxs2 (and libtool, indirectly) doesn't look there. Weird.

So, I ran 'make' once to produce the .so, then moved the file manually from .libs to the current directory, then ran 'make' again, which completed the process.

Also, I had to revert to gcc-3.4 from the gcc-4.0, which produced errors in addition to many warnings about signedness mismatches.

Thanks to Sean and Stuart for the help!


----- Original Message -----
From: Stuart Williams <stuartw at mts.net>
Date: Wednesday, June 7, 2006 9:34 pm
Subject: Re: [RndTbl] Apache2 modules

> >>>>> Kevin McGregor writes:
> > I'm trying to compile the mod_ntlm2 module, and it's failing to
> > produce the mod_ntlm.so but I can't figure out precisely why. Does
> > anyone have any suggestions?
> > user at hostname:~/mod_ntlm# make install
> > apxs2 -c -o mod_ntlm.so -Wc,-shared mod_ntlm.c
> > apxs2 -i -a -n 'ntlm' mod_ntlm.so
> I ran into a similar problem 9 months ago and according to my 
> notes of
> the problem and its resolution, I worked around it quickly by adding
> the installation option(s) in the second apxs2 command to the first
> one.  It's not obvious to me from the apxs2 code why this workaround
> helped.
> Stuart Williams.
> _______________________________________________
> Roundtable mailing list
> Roundtable at muug.mb.ca
> http://www.muug.mb.ca/mailman/listinfo/roundtable

More information about the Roundtable mailing list