[RndTbl] TTY1 and Starting X Windows

Montana Quiring montanaq at gmail.com
Tue Apr 18 11:42:42 CDT 2006


Thanks for your feedback at the last MUUG meeting about the problem I had
with Control+C droping someone to a shell prompt in the forst TTY.

I had a google group thread here if you want to read/respond there:

I changed the line in /etc/inittab from:
1:2345:respawn:/bin/bash -login > /dev/tty1 2>&1 < /dev/tty1
1:2345:respawn:/sbin/getty 38400 tty1

and that solves to problem of getting to a shell but now X Windows doesn't

I don't fully understand what the orig line is doing and I think that's my

I tried to put a Control C trap in ~.bash_profile, ~.bashrc,
/etc/profile /etc/bash.bashrc by putting this line it:
trap "" 2
It works after the X server has been killed but doesn't seem to stop my
from pressing Control C to kill it.

Maybe I'm going about this all wrong.
If I run /sbin/getty in the inittab how do I get it to start X?

Any help would be appreciated.

"When I give, I give myself.”
-Walt Whitman

More information about the Roundtable mailing list