[RndTbl] the at command

millward millward at Ms.UManitoba.CA
Tue Sep 17 15:23:40 CDT 2002

I can't get the at command to work. I've tried
all kinds of stuff and either it can't find the file,
or creates a job in the at que, and then fails to run it.
For example:
         at 2:10pm today < /usr/my_c/showenv
showenv is entered as a job in the at que, but never runs.
The que is empty after 2:10pm.
        at  -f  /my_c/curs/hello  2:10pm today
Again, its entered as a job, but when execution
time comes all I get is an error message saying
it couldn't find the file.   
       Both hello and showenv are C executable programs
with root permissions. I'm executing at as root on the
command line.
    I've also tried a simple script called ruff.
  ehco "Hello. This is a Test."
I gave ruff   chmod 777 ruff
   Tried to get at to run ruff with
    at -f /usr/my_c/ruff  3:15pm today
It was placed in the at que. I saw it as job 5 using atq.
But when the time came, nothing happened and the que emptied.
    Could someone tell me what I'm doing wrong?

More information about the Roundtable mailing list